A list of RFCs we do and don't support. | RFC | Status | | [[https://tools.ietf.org/html/rfc793|RFC 793]] - TCP | ✔ supported | | [[https://tools.ietf.org/html/rfc813|RFC 813]] - Window and Acknowledgement Strategy in TCP | :idea: informational | | [[https://tools.ietf.org/html/rfc814|RFC 814]] - Name, Addresses, Ports, and Routes | :idea: informational | | [[https://tools.ietf.org/html/rfc816|RFC 816]] - Fault Isolation and Recovery | :idea: informational | | [[https://tools.ietf.org/html/rfc817|RFC 817]] - Modularity and Efficiency in Protocol Implementation | :idea: informational | | [[https://tools.ietf.org/html/rfc872|RFC 872]] - TCP-ON-A-LAN | :idea: informational | | [[https://tools.ietf.org/html/rfc879|RFC 879]] - The TCP Maximum Segment Size and Related Topics | :!: unknown | | [[https://tools.ietf.org/html/rfc896|RFC 896]] - Congestion Control in IP/TCP Internetworks | :idea: informational | | [[https://tools.ietf.org/html/rfc964|RFC 964]] - Some Problems with the Specification of the Military | :idea: informational | | [[https://tools.ietf.org/html/rfc1071|RFC 1071]] - Computing the Internet Checksum | :!: unknown | | [[https://tools.ietf.org/html/rfc1072|RFC 1072]] - TCP Extensions for Long-Delay Paths | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1106|RFC 1106]] - TCP Big Window and NAK Options | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1110|RFC 1110]] - A Problem with the TCP Big Window Option | :idea: informational | | [[https://tools.ietf.org/html/rfc1122|RFC 1122]] - Requirements for Internet Hosts - Communication Layers | :idea: informational | | [[https://tools.ietf.org/html/rfc1146|RFC 1146]] - TCP Alternate Checksum Options | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1156|RFC 1156]] - Management Information Base for Network Management of TCP/IP-based Internets | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1180|RFC 1180]] - TCP/IP Tutorial | :idea: informational | | [[https://tools.ietf.org/html/rfc1185|RFC 1185]] - TCP Extension for High-Speed Paths | :idea: informational | | [[https://tools.ietf.org/html/rfc1191|RFC 1191]] - Path MTU Recovery | :!: unknown | | [[https://tools.ietf.org/html/rfc1213|RFC 1213]] - Management Information Base for Network Management of TCP/IP-based Internets: MIB-II | :!: unknown | | [[https://tools.ietf.org/html/rfc1263|RFC 1263]] - TCP Extensions Considered Harmful | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1323|RFC 1323]] - TCP Extensions for High Performance | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1379|RFC 1379]] - Extending TCP for Transactions -- Concepts | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1470|RFC 1470]] - FYI on a Network Management Tool Catalog: Tools for Monitoring and Debugging TCP/IP Internets and Interconnected Devices | :idea: informational | | [[https://tools.ietf.org/html/rfc1624|RFC 1624]] - Computation of the Internet Checksum via Incremental Update | :!: unknown | | [[https://tools.ietf.org/html/rfc1644|RFC 1644]] - T/TCP -- TCP Extensions for Transactions Functional Specification | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1693|RFC 1693]] - An Extension to TCP: Partial Order Service | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc1936|RFC 1936]] - Implementing the Internet Checksum in Hardware | :idea: informational | | [[https://tools.ietf.org/html/rfc1948|RFC 1948]] - Defending Against Sequence Number Attacks | :!: unknown | | [[https://tools.ietf.org/html/rfc2012|RFC 2012]] - SNMPv2 Management Information Base for the Transmission Control Protocol using SMIv2 | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc2018|RFC 2018]] - TCP Selective Acknowledgment Options | ✔ supported | | [[https://tools.ietf.org/html/rfc2140|RFC 2140]] - TCP Control Block Interdependence | :idea: informational | | [[https://tools.ietf.org/html/rfc2398|RFC 2398]] - Some Testing Tools for TCP Implementors | :idea: informational | | [[https://tools.ietf.org/html/rfc2452|RFC 2452]] - IP Version 6 Management Information Base for the Transmission Control Protocol | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc2488|RFC 2488]] - Enhancing TCP Over Satellite Channels using Standard Mechanisms | :idea: informational | | [[https://tools.ietf.org/html/rfc2525|RFC 2525]] - Known TCP Implementation Problems | :idea: informational | | [[https://tools.ietf.org/html/rfc2581|RFC 2581]] - TCP Congestion Control | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc2757|RFC 2757]] - Long Thin Networks | :idea: informational | | [[https://tools.ietf.org/html/rfc2760|RFC 2760]] - Ongoing TCP Research Related to Satellites | :idea: informational | | [[https://tools.ietf.org/html/rfc2861|RFC 2861]] - TCP Congestion Window Validation | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc2873|RFC 2873]] - TCP Processing of the IPv4 Precedence Field | ✔ supported | | [[https://tools.ietf.org/html/rfc2883|RFC 2883]] - An Extension to the Selective Acknowledgement | ✘ unsupported | | [[https://tools.ietf.org/html/rfc2914|RFC 2914]] - Congestion Control Principles | :idea: informational | | [[https://tools.ietf.org/html/rfc2923|RFC 2923]] - TCP Problems with Path MTU Discovery | :idea: informational | | [[https://tools.ietf.org/html/rfc2988|RFC 2988]] - Computing TCP's Retransmission Timer | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc3042|RFC 3042]] - Enhancing TCP's Loss Recovery Using Limited Transmit | ✔ supported | | [[https://tools.ietf.org/html/rfc3135|RFC 3135]] - Performance Enhancing Proxies Intended to Mitigate | :idea: informational | | [[https://tools.ietf.org/html/rfc3150|RFC 3150]] - End-to-end Performance Implications of Slow Links | :!: unknown | | [[https://tools.ietf.org/html/rfc3155|RFC 3155]] - End-to-end Performance Implications of Links with Errors | :!: unknown | | [[https://tools.ietf.org/html/rfc3168|RFC 3168]] - The Addition of Explicit Congestion Notification (ECN) to IP | :!: unknown | | [[https://tools.ietf.org/html/rfc3360|RFC 3360]] - Inappropriate TCP Resets Considered Harmful | :!: unknown | | [[https://tools.ietf.org/html/rfc3366|RFC 3366]] - Advice to link designers on link Automatic Repeat reQuest (ARQ) | :!: unknown | | [[https://tools.ietf.org/html/rfc3390|RFC 3390]] - Increasing TCP's Initial Window | ✔ supported | | [[https://tools.ietf.org/html/rfc3449|RFC 3449]] - TCP Performance Implications of Network Path Asymmetry | :!: unknown | | [[https://tools.ietf.org/html/rfc3465|RFC 3465]] - TCP Congestion Control with Appropriate Byte Counting | ✔ supported | | [[https://tools.ietf.org/html/rfc3481|RFC 3481]] - TCP over Second (2.5G) and Third (3G) Generation Wireless Networks | :!: unknown | | [[https://tools.ietf.org/html/rfc3493|RFC 3493]] - Basic Socket Interface Extensions for IPv6 | :!: unknown | | [[https://tools.ietf.org/html/rfc3517|RFC 3517]] - A Conservative Selective Acknowledgment (SACK)-based Loss Recovery Algorithm for TCP | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc3522|RFC 3522]] - The Eifel Detection Algorithm for TCP | ✘ unsupported | | [[https://tools.ietf.org/html/rfc3540|RFC 3540]] - Robust Explicit Congestion Notification (ECN) signaling | ✔ supported | | [[https://tools.ietf.org/html/rfc3649|RFC 3649]] - %%HighSpeed%% TCP for Large Congestion Windows | :!: unknown | | [[https://tools.ietf.org/html/rfc3708|RFC 3708]] - Using TCP Duplicate Selective Acknowledgement (DSACKs) | ✔ supported (11+) | | [[https://tools.ietf.org/html/rfc3742|RFC 3742]] - Limited Slow-Start for TCP with Large Congestion) | :!: unknown | | [[https://tools.ietf.org/html/rfc3782|RFC 3782]] - The %%NewReno%% Modification to TCP's Fast Recovery | %%|%%-) obsolete | | [[https://tools.ietf.org/html/rfc3819|RFC 3819]] - Advice for Internet Subnetwork Designers | :!: unknown | | [[https://tools.ietf.org/html/rfc4015|RFC 4015]] - The Eifel Response Algorithm for TCP | ✘ unsupported | | [[https://tools.ietf.org/html/rfc4022|RFC 4022]] - Management Information Base for the Transmission Control Protocol (TCP) | :!: unknown | | [[https://tools.ietf.org/html/rfc4138|RFC 4138]] - Forward RTO-Recovery (F-RTO): An Algorithm for Detecting) | :!: unknown | | [[https://tools.ietf.org/html/rfc4653|RFC 4653]] - TCP-NCR Improving the Robustness of TCP to Non-Congestion Events | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5482|RFC 5482]] - TCP User Timeout Option (UTO) | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5562|RFC 5562]] - ECN capability on SYN/ACK (ECN+) | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5681|RFC 5681]] - TCP Congestion Control | ✔ supported | | [[https://tools.ietf.org/html/rfc5682|RFC 5682]] - Forward RTO-Recovery (F-RTO) | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5690|RFC 5690]] - Adding Acknowledgement Congestion Control to TCP | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5827|RFC 5827]] - Early Retransmit for TCP and SCTP | ✘ unsupported | | [[https://tools.ietf.org/html/rfc5961|RFC 5961]] - Improving TCP's Robustness to Blind In-Window Attacks | {*} Partially supported | | [[https://tools.ietf.org/html/rfc6298|RFC 6298]] - Computing TCP's Retransmission Timer | {*} Partially supported | | [[https://tools.ietf.org/html/rfc6363|RFC 6363]] - Forward Error Correction (FEC) Framework | ✘ unsupported | | [[https://tools.ietf.org/html/rfc6582|RFC 6582]] - The %%NewReno%% Modification to TCP's Fast Recovery Algorithm | ✔ supported | | [[https://tools.ietf.org/html/rfc6675|RFC 6675]] - A Conservative Loss Recovery Algorithm Based on SACK | {*} Partially supported | | [[https://tools.ietf.org/html/rfc6928|RFC 6928]] - Increasing TCP's Initial Window | ✔ supported | | [[https://tools.ietf.org/html/rfc6937|RFC 6937]] - Proportional Rate Reduction (PRR) | ✔ supported | | [[https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-prr-rfc6937bis|RFC 6937bis]] - Proportional Rate Reduction (PRR) | {*} work-in-progress | | [[https://tools.ietf.org/html/rfc7323|RFC 7323]] - TCP Extensions for High Performance | {*} Partially supported | | [[https://tools.ietf.org/html/rfc7413|RFC 7413]] - TCP Fast Open | {*} Partially supported | | [[https://tools.ietf.org/html/rfc7414|RFC 7414]] - TCP Roadmap | :idea: informational | | [[https://tools.ietf.org/html/rfc7661|RFC 7661]] - Updating TCP to Support Rate-Limited Traffic | :!: unknown | | [[https://tools.ietf.org/html/rfc8312|RFC 8312]] - TCP Cubic for long distance links | ✔ supported | | [[https://datatracker.ietf.org/doc/draft-ietf-tcpm-rfc8312bis/|RFC 8312bis]] - TCP Cubic for long distance links | {*} work-in-progress | | [[https://tooos.ietf.org/html/rfc8257|RFC 8257]] - Datacenter TCP (DCTCP) | {*} Partially supported | | [[https://tools.ietf.org/html/rfc8511|RFC 8511]] - Alternative Backoff for ECN (ABE) | ✘ unsupported | | ECN++ - Adding ECN to control packets | ✘ unsupported | | RACK - Recent Acknowledgement | ✔ supported | | BBRv1 - Bottleneck Bandwidth and RRT | {*} Partially supported | | %%AccECN%% - Accuarate ECN Feedback | {*} Partially supported |