Show pageOld revisionsBacklinksBack to top This page is read only. You can view the source, but not change it. Ask your administrator if you think this is wrong. ====== Hangout 06 June 2019 ====== ==== Old Business ==== * IPv6 Fragment reviews which need testing: * Eliminate KAME circular queues: [[https://reviews.freebsd.org/D16847|D16847]]. * Drop packets with overlapping fragments: [[https://reviews.freebsd.org/D16850|D16850]]. * IPv6 modernization project: [[/IPv6|Wiki Page]] * Julius proposed importing %%OpenBSD%% fragmentation regression test cases (see [[https://reviews.freebsd.org/D17376|D17376]]). thj@ is working on it. * Drop from list: need to be re-written. * [[https://tools.ietf.org/html/rfc7112|RFC 7112]] [[https://reviews.freebsd.org/D16851|D16851]]. * Just updated. Tom will mercilessly harass jtl@ until he reviews it. * IP6 IDs (and IP IDs, maybe?): may use an insecure algorithm. Ideally, switch to some sort of per-host-pair hash? * What do %%OpenBSD%%/%%NetBSD%% do? * tuexen: %%OpenBSD%% does skip32. We use a linear congruential algorithm. %%NetBSD%% uses the same algorithm we do. * See [[https://dl.packetstormsecurity.net/papers/attack/OpenBSD_DNS_Cache_Poisoning_and_Multiple_OS_Predictable_IP_ID_Vulnerability.pdf|paper]]. * Perhaps, a small cache would be sufficient? * [[https://tools.ietf.org/html/rfc7739|RFC 7739]] provides three different options to consider. * Absent a compelling application that needs this, put any changes on hold. * jtl@ to send patch to Richard for burst mitigation in the default stack. An idea is in [[https://reviews.freebsd.org/D19047|D19047]]. * Still need to do. :-( * [[https://reviews.freebsd.org/D18811|D18811]]: standardize on snd_recover (vs. sack_newdata). Reviewer: tuexen@, lstewart@. * @tuexen will review again. * [[https://reviews.freebsd.org/D18624|D18624]]: [[https://tools.ietf.org/html/rfc6675|RFC 6675]] support. Actual functionality in [[https://reviews.freebsd.org/D18985|D18985]]. * Helps when HW LRO is enabled. * Also, this enables a PRR patch (based on Lars work). [[https://reviews.freebsd.org/D18892|D18892]]. Needs review. * CUBIC: Only invoking %%NewReno%% after_idle, not resetting ssthreash, not resetting epoch time: [[https://reviews.freebsd.org/D18982|D18982]], [[https://reviews.freebsd.org/D18954|D18954]], and [[https://reviews.freebsd.org/D19118|D19118]]. Including another issue, this will be discussed at the IETF. * lstewart@ is the best person to review this. * [[https://reviews.freebsd.org/D19000|D19000]] deal with a bug that the 1 byte occupied in the sequence number space by SYN segments results in a cwnd increase when acked. This bug exists only on the server side. tuexen@ and Richard are working on it. * Richard is working on burst mitigation. An initial version (WIP) is available as [[https://reviews.freebsd.org/D19047|D19047]]. * tun/tap interfaces: should we see outgoing packets in tcpdump? * Currently inconsistent. In general, yes, these should be visible. * There was a re-write of tun/tap interfaces in the meantime. tuexen@ will re-evaluate. * Items for future discussion (based on BSDCan discussions): * Revisit how we maintain multiple TCP stacks * Revisit CC API * Talk about further network modularity (as requested by Juniper) * hps@ gives update on [[https://reviews.freebsd.org/D20080|D20080]]. * markj@ reviewing. * hps@ asks about [[https://reviews.freebsd.org/D19622|D19622]]. * Feedback: because fragments are not tied to arrival interface, it doesn't make sense to drop fragments. * jtl@ to summarize conversation in review. Hopefully, we can have a real-time conversation on the call in 2 weeks. * tuexen@ committed [[https://reviews.freebsd.org/D20372|D20372]]. ==== New Things ==== * Richard reports %%NetApp%% is testing DC-TCP. ==== Next Meeting ==== Scheduled for 20 June, 14:00 UTC. transportprotocols/06jun2019.txt Last modified: 2019/06/12 01:44by MarkLinimon