A list of RFCs we do and don't support.
| RFC | Status |
| RFC 793 - TCP | ✔ supported |
| RFC 813 - Window and Acknowledgement Strategy in TCP | :idea: informational |
| RFC 814 - Name, Addresses, Ports, and Routes | :idea: informational |
| RFC 816 - Fault Isolation and Recovery | :idea: informational |
| RFC 817 - Modularity and Efficiency in Protocol Implementation | :idea: informational |
| RFC 872 - TCP-ON-A-LAN | :idea: informational |
| RFC 879 - The TCP Maximum Segment Size and Related Topics | |
| RFC 896 - Congestion Control in IP/TCP Internetworks | :idea: informational |
| RFC 964 - Some Problems with the Specification of the Military | :idea: informational |
| RFC 1071 - Computing the Internet Checksum | |
| RFC 1072 - TCP Extensions for Long-Delay Paths | |-) obsolete |
| RFC 1106 - TCP Big Window and NAK Options | |-) obsolete |
| RFC 1110 - A Problem with the TCP Big Window Option | :idea: informational |
| RFC 1122 - Requirements for Internet Hosts - Communication Layers | :idea: informational |
| RFC 1146 - TCP Alternate Checksum Options | |-) obsolete |
| RFC 1156 - Management Information Base for Network Management of TCP/IP-based Internets | |-) obsolete |
| RFC 1180 - TCP/IP Tutorial | :idea: informational |
| RFC 1185 - TCP Extension for High-Speed Paths | :idea: informational |
| RFC 1191 - Path MTU Recovery | |
| RFC 1213 - Management Information Base for Network Management of TCP/IP-based Internets: MIB-II | |
| RFC 1263 - TCP Extensions Considered Harmful | |-) obsolete |
| RFC 1323 - TCP Extensions for High Performance | |-) obsolete |
| RFC 1379 - Extending TCP for Transactions – Concepts | |-) obsolete |
| RFC 1470 - FYI on a Network Management Tool Catalog: Tools for Monitoring and Debugging TCP/IP Internets and Interconnected Devices | :idea: informational |
| RFC 1624 - Computation of the Internet Checksum via Incremental Update | |
| RFC 1644 - T/TCP – TCP Extensions for Transactions Functional Specification | |-) obsolete |
| RFC 1693 - An Extension to TCP: Partial Order Service | |-) obsolete |
| RFC 1936 - Implementing the Internet Checksum in Hardware | :idea: informational |
| RFC 1948 - Defending Against Sequence Number Attacks | |
| RFC 2012 - SNMPv2 Management Information Base for the Transmission Control Protocol using SMIv2 | |-) obsolete |
| RFC 2018 - TCP Selective Acknowledgment Options | ✔ supported |
| RFC 2140 - TCP Control Block Interdependence | :idea: informational |
| RFC 2398 - Some Testing Tools for TCP Implementors | :idea: informational |
| RFC 2452 - IP Version 6 Management Information Base for the Transmission Control Protocol | |-) obsolete |
| RFC 2488 - Enhancing TCP Over Satellite Channels using Standard Mechanisms | :idea: informational |
| RFC 2525 - Known TCP Implementation Problems | :idea: informational |
| RFC 2581 - TCP Congestion Control | |-) obsolete |
| RFC 2757 - Long Thin Networks | :idea: informational |
| RFC 2760 - Ongoing TCP Research Related to Satellites | :idea: informational |
| RFC 2861 - TCP Congestion Window Validation | |-) obsolete |
| RFC 2873 - TCP Processing of the IPv4 Precedence Field | ✔ supported |
| RFC 2883 - An Extension to the Selective Acknowledgement | ✘ unsupported |
| RFC 2914 - Congestion Control Principles | :idea: informational |
| RFC 2923 - TCP Problems with Path MTU Discovery | :idea: informational |
| RFC 2988 - Computing TCP's Retransmission Timer | |-) obsolete |
| RFC 3042 - Enhancing TCP's Loss Recovery Using Limited Transmit | ✔ supported |
| RFC 3135 - Performance Enhancing Proxies Intended to Mitigate | :idea: informational |
| RFC 3150 - End-to-end Performance Implications of Slow Links | |
| RFC 3155 - End-to-end Performance Implications of Links with Errors | |
| RFC 3168 - The Addition of Explicit Congestion Notification (ECN) to IP | |
| RFC 3360 - Inappropriate TCP Resets Considered Harmful | |
| RFC 3366 - Advice to link designers on link Automatic Repeat reQuest (ARQ) | |
| RFC 3390 - Increasing TCP's Initial Window | ✔ supported |
| RFC 3449 - TCP Performance Implications of Network Path Asymmetry | |
| RFC 3465 - TCP Congestion Control with Appropriate Byte Counting | ✔ supported |
| RFC 3481 - TCP over Second (2.5G) and Third (3G) Generation Wireless Networks | |
| RFC 3493 - Basic Socket Interface Extensions for IPv6 | |
| RFC 3517 - A Conservative Selective Acknowledgment (SACK)-based Loss Recovery Algorithm for TCP | |-) obsolete |
| RFC 3522 - The Eifel Detection Algorithm for TCP | ✘ unsupported |
| RFC 3540 - Robust Explicit Congestion Notification (ECN) signaling | ✔ supported |
| RFC 3649 - HighSpeed TCP for Large Congestion Windows | |
| RFC 3708 - Using TCP Duplicate Selective Acknowledgement (DSACKs) | ✔ supported (11+) |
| RFC 3742 - Limited Slow-Start for TCP with Large Congestion) | |
| RFC 3782 - The NewReno Modification to TCP's Fast Recovery | |-) obsolete |
| RFC 3819 - Advice for Internet Subnetwork Designers | |
| RFC 4015 - The Eifel Response Algorithm for TCP | ✘ unsupported |
| RFC 4022 - Management Information Base for the Transmission Control Protocol (TCP) | |
| RFC 4138 - Forward RTO-Recovery (F-RTO): An Algorithm for Detecting) | |
| RFC 4653 - TCP-NCR Improving the Robustness of TCP to Non-Congestion Events | ✘ unsupported |
| RFC 5482 - TCP User Timeout Option (UTO) | ✘ unsupported |
| RFC 5562 - ECN capability on SYN/ACK (ECN+) | ✘ unsupported |
| RFC 5681 - TCP Congestion Control | ✔ supported |
| RFC 5682 - Forward RTO-Recovery (F-RTO) | ✘ unsupported |
| RFC 5690 - Adding Acknowledgement Congestion Control to TCP | ✘ unsupported |
| RFC 5827 - Early Retransmit for TCP and SCTP | ✘ unsupported |
| RFC 5961 - Improving TCP's Robustness to Blind In-Window Attacks | {*} Partially supported |
| RFC 6298 - Computing TCP's Retransmission Timer | {*} Partially supported |
| RFC 6363 - Forward Error Correction (FEC) Framework | ✘ unsupported |
| RFC 6582 - The NewReno Modification to TCP's Fast Recovery Algorithm | ✔ supported |
| RFC 6675 - A Conservative Loss Recovery Algorithm Based on SACK | {*} Partially supported |
| RFC 6928 - Increasing TCP's Initial Window | ✔ supported |
| RFC 6937 - Proportional Rate Reduction (PRR) | ✔ supported |
| RFC 6937bis - Proportional Rate Reduction (PRR) | {*} work-in-progress |
| RFC 7323 - TCP Extensions for High Performance | {*} Partially supported |
| RFC 7413 - TCP Fast Open | {*} Partially supported |
| RFC 7414 - TCP Roadmap | :idea: informational |
| RFC 7661 - Updating TCP to Support Rate-Limited Traffic | |
| RFC 8312 - TCP Cubic for long distance links | ✔ supported |
| RFC 8312bis - TCP Cubic for long distance links | {*} work-in-progress |
| RFC 8257 - Datacenter TCP (DCTCP) | {*} Partially supported |
| RFC 8511 - Alternative Backoff for ECN (ABE) | ✘ unsupported |
| ECN++ - Adding ECN to control packets | ✘ unsupported |
| RACK - Recent Acknowledgement | ✔ supported |
| BBRv1 - Bottleneck Bandwidth and RRT | {*} Partially supported |
| AccECN - Accuarate ECN Feedback | {*} Partially supported |